News

News


DomainMOD v4.15 Released -- Gandi & Namecheap APIs, PHP 5.3 & 5.4 are out!
Sunday, May 17th, 2020

After what seems like forever, as of DomainMOD v4.15, support has been added for Gandi's API. Gandi has been our highest requested API integrations by far, so it's nice to finally be able to make it happen.

We've personally wanted to implement Gandi's API for many, many years, as we're a fan of Gandi, however their old API required the use of an outdated PHP library which hadn't been worked on in years and could potentially have security vulnerabilities, and this is in addition to the fact that the API usage was a bit of a nightmare.

Well, luckily none of that matters anymore! Gandi recently implemented a new API, one that was very easy to implement, and it didn't require any 3rd party libraries that could potentially become oudated.

In other API news, a fix has been implemented for the Namecheap API that prevented you from importing more than 100 domains. Thanks to amasmuggleavocados on GitHub for the fix!

Lastly, due to some increased password security measures that were recently implemented, which are not compatible with PHP v5.3 and v5.4, we have made the decision to deprecate support for these PHP versions. We try to make DomainMOD work well on older PHP versions, however these two PHP versions reached their official end-of-life 5+ years ago, so it didn't make sense to keep supporting them at the cost of decreased password security.